Jekyll

Setup Jekyll Environment

Jekyll requires the following:

  • Ruby version 2.4.0 or higher | rbenv

  • RubyGems

  • GCC and Make

gem install jekyll bundler
jekyll new myblog
cd myblog
bundle exec jekyll serve

Use Bundler 2 Or Greater With This Lockfile

source

warn_for_outdated_bundler_version': You must use Bundler 2 or greater with this lockfile. (Bundler::LockfileError)

To use Bundler 2 in your lockfile:

# update Rubygems
gem update --system
# update bundler
gem install bundler
# update Gemfile.lock in your project
bundler update --bundler